Informatica, hardware e software

Informatica, hardware e software

Suggerimenti, consigli e richieste sul mondo dell'informatica.

linx linx 10/10/2008 ore 15.10.50
segnala

(Nessuno)RE: ubuntu....

A robi970 che il 10/10/2008 12.57.47 ha scritto:

azzzzzzz.....

ho un problema ke di per sé è una cavolata, ma ho il timore di commettere errori e fare danni:
ubuntu mi mostra le varie cartelle nelle partizioni ke ho sull'HD di "windows" con un lukketto (anke nelle partizioni senza SO), tanto ke non mi permette di salvarci files mp3/wav....
come posso togliere il lukketto in totale sicurezza, senza cioè il riskio di perdere i dati su qlle partizioni? è sufficiente cliccare col tasto destro sulla cartella bloccata o occorre una procedura più complessa?

grazie ancora

Rispondo:


Errori?

Ma chettifrega.

Lo disinstalli e lo reinstalli.

Come lo hai instalato?

Col CD o da Windows?

robi970 robi970 10/10/2008 ore 16.09.31 Ultimi messaggi
segnala

(Nessuno)RE: ubuntu....


la mia paura, linx, è di fare qlke manovra ke mi fa perdere i dati all'interno della partizione ke ha il lukketto.....
capisco ke la mia sia solo una paura infondata, ma come si dice:
meglio aver paura ke toccarne ;-)
Stregatt0 Stregatt0 11/10/2008 ore 15.47.18 Ultimi messaggi
segnala

(Nessuno)RE: ubuntu....

La partizione letta ha il lucchetto perchè come utente non hai i permessi per leggerla.
Le strade per risolvere il problema sono più di una, la migliore a mio avviso è quella di editare a mano il file /etc/fstab che è il file che gestisce i mount d'avvio ed una volta individuate le due partizioni basta aggiungere i flag "users" e volendo anche "auto" in modo che la monti all'avvio del pc.

Un esempio dal mio file fstab è:
/dev/sda5 /media/dati ntfs rw,user,users,auto 0 0
dove:
/dev/sda5 è il file della partizione
/media/dati è la cartella dove viene montata la partizione
ntfs è il file system
i flag rw (lettura/scrittura),user,users (accesso ad utenti),auto (montaggio all'avvio) definiscono come dev'essere gestita la partizione
lo zero è il no all'opzione di backup
l'altro zero è il no al check del filesystem all'avvio.
robi970 robi970 11/10/2008 ore 17.51.01 Ultimi messaggi
segnala

(Nessuno)RE: ubuntu....


ok, ancora grazie stregatto :-)

....ma secondo te, xké nella stessa partizione alcune cartelle hanno il lukketto ed altre no?.... ke criterio ha usato linux x metterlo?
esempio:
nella partizione "musica" (fat32) mi ritrovo la cartella "italiane" e "disco" col lukketto, mentre qlla "blues" senza.....
stessa situazione nella partizione "varie" (fat32) dove la cartella "personale" è libera, mentre qlla "animazioni" è protetta...
non so se sia un caso, ma nella partizione "files temporanei" (ntfs) non ci sono lukketti

:nono1 mah...
Stregatt0 Stregatt0 11/10/2008 ore 18.09.10 Ultimi messaggi
segnala

(Nessuno)RE: ubuntu....

Non sono sicuro ma penso dipenda da come legge linux il filesystem e in caso di "anomalie" dà la proprietà della cartella al root.
Il problema si risolve facilmente con un sudo chmod 0777 /media/partizioneX -R che dà libertà di lettura e scrittura a tutti gli utenti sulla cartella e sotto cartella specificata.

Mentre l'edit del file fstab lavora sulla partizione, il chmod lavora sui permessi dei vari utenti su una precisa cartella o file

Rispondi al messaggio

Per scrivere un nuovo messaggio è necessario accedere al sito.